Прибавь 2.2. Умножь на 2.Первая из них увеличивает число на экране на
Условие
Исполнитель преобразует число на экране.У исполнителя есть две команды, которым присвоены номера.1. Прибавь 2.2. Умножь на 2.Первая из них увеличивает число на экране на 2, вторая увеличивает число на экране в два раза.
Программа для исполнителя — это последовательность команд.
Сколько существует программ, для которых при исходном числе 1 результатом является число 52 и при этом траектория вычислений содержит число 18?Траектория вычислений программы — это последовательность результатов выполнения всех команд программы. Например, для программы 121 при исходном числе 3 траектория будет состоять из чисел 5, 10, 12.
Ответ
Ответ и полный разбор откроются после входа
Посмотреть ответРешение по шагам
Как рассуждать
Решение. Приведём программу на PascalABC, решающую данную задачу:var n: integer;function F(n: integer; m: integer): integer; begin if n > m then F := 0 else if n = m then F := 1 else F := F(n + 2, m) + F(n * 2, m) end; begin writeln(F(1,
Осталось ещё 2 шага
* F(18, 52))end.Результат работы программы…
Приведём другое решение на языке Python.def…
Бесплатно · займёт минуту