Присоединиться

11 класс·средний уровень

Сколько существует программ, которые преобразуют исходное число 1 в

Условие

Исполнитель РазДваПять преобразует число на экране.У исполнителя есть три команды, которым присвоены номера.1. Прибавить 1.2. Умножить на 2.3. Прибавить 5.Первая команда увеличивает число на экране на 1, вторая умножает его на 2, третья увеличивает на 5.Программа для исполнителя РазДваПять — это последовательность команд.

Сколько существует программ, которые преобразуют исходное число 1 в число 16, и при этом траектория вычислений содержит число 8 и не содержит числа 10?Траектория вычислений — это последовательность результатов выполнения всех команд программы. Например, для программы 312 при исходном числе 4 траектория будет состоять из чисел 9, 10, 20.

Ответ

Ответ и полный разбор откроются после входа

Посмотреть ответ

Решение по шагам

  1. Как рассуждать

    Решение. Искомое количество программ равно количеству программ, получающих из числа 1 число

Осталось ещё 9 шагов

  1. Траектория вычислений не должна содержать…

  2. (если n чётно) + R(n - 5). R(2) = 2;R(3) =…

  3. Таким образом, количество программ…

  4. Приведем другое решение. Количество программ…

  5. (если n чётно) + R(n - 5). R(2) = 2;R(3) =…

  6. Приведём другое решение на языке Python. def…

  7. * f(8, 16)) Приведём решение Виктории…

  8. return 0; if (from == to) return 1; int…

  9. * count_trs(8, 16); printf("%d ", count)…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Оператор присваивания и ветвления. Перебор вариантов»

Сколько существует программ, которые преобразуют исходное число 1 в — решение с объяснением | Lom Ai