Присоединиться

11 класс·средний уровень

Определите количество принадлежащих отрезку [345 678; 456 789]

Условие

Определите количество принадлежащих отрезку [345 678; 456 789] натуральных чисел, которые делятся без остатка на сумму своих цифр, и наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем наименьшее число. Числа в ответ запишите друг за другом без разделительных знаков.

Ответ

Ответ и полный разбор откроются после входа

Посмотреть ответ

Решение по шагам

  1. Как рассуждать

    Решение. Решим задачу перебором. Приведём решение данной задачи на языке PascalABC:var i, j, count, min, sum: longint;s: string;begin count := 0; min := 500000; for i := 345678 to 456789 do begin s := inttostr(i); sum := 0; for j := 1 to 6 do sum := sum + strtoint(s[j]); if i mod sum = 0 then begin count := count + 1; if i < min then min := i; end; end; writeln(count, min);end.Результат работы программы —

Осталось ещё 1 шаг

  1. Полный разбор с проверкой ответа

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Проверка на делимость»

Определите количество принадлежащих отрезку [345 678; 456 789] — решение с объяснением | Lom Ai