Присоединиться

11 класс·средний уровень

Найдите количество таких чисел и максимальное из них.

Условие

Рассматривается множество целых чисел, принадлежащих числовому отрезку [1016; 7937], которые делятся на 3 и не делятся на 7, 17, 19, 27. Найдите количество таких чисел и максимальное из них. В ответе запишите два целых числа без пробелов и других дополнительных символов: сначала количество, затем максимальное число.

Для выполнения этого задания можно написать программу или воспользоваться редактором электронных таблиц.

Ответ

Ответ и полный разбор откроются после входа

Посмотреть ответ

Решение по шагам

  1. Как рассуждать

    Решение. Приведём решение данной задачи на языке Паскаль:var sum, max, i: integer;begin max := 0; sum := 0; for i := 1016 to 7937 do begin if i mod 3 = 0 then if i mod 7 <> 0 then if i mod 17 <> 0 then if i mod 19 <> 0 then if i mod 27 <> 0 then begin sum := sum + 1; if i > max then max := i; end; end; writeln(sum, max);end.

Осталось ещё 1 шаг

  1. Приведём решение Юрия Красильникова на языке…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Проверка на делимость»