Определите количество принадлежащих отрезку [123 456; 234 567]
Условие
Определите количество принадлежащих отрезку [123 456; 234 567] натуральных чисел, которые делятся без остатка на сумму своих цифр, и наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем наименьшее число. Числа в ответ запишите друг за другом без разделительных знаков.
Ответ
Ответ и полный разбор откроются после входа
Посмотреть ответРешение по шагам
Как рассуждать
Решение. Решим задачу перебором. Приведём решение данной задачи на языке PascalABC:var i, j, count, min, sum: longint;s: string;begin count := 0; min := 300000; for i := 123456 to 234567 do begin s := inttostr(i); sum := 0; for j := 1 to 6 do sum := sum + strtoint(s[j]); if i mod sum = 0 then begin count := count + 1; if i < min then min := i; end; end; writeln(count, min);end.Результат работы программы —
Осталось ещё 1 шаг
Полный разбор с проверкой ответа
Бесплатно · займёт минуту