Определите количество подходящих чисел, принадлежащих отрезку [50 001
Условие
Назовём натуральное число подходящим, если у него ровно 3 различных простых делителя. Например, число 180 подходящее (его простые делители — 2, 3 и 5), а число 12 — нет (у него только два различных простых делителя). Определите количество подходящих чисел, принадлежащих отрезку [50 001; 90 000], а также наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем наименьшее число.
Ответ
Ответ и полный разбор откроются после входа
Посмотреть ответРешение по шагам
Как рассуждать
Решение. Решим задачу перебором. Приведём решение данной задачи на языке PascalABC:var del1, del2, count, min, i, j, k: longint;begin count := 0; del1 := 0; del2 := 0; min := 90001; for i := 50001 to 90000 do begin for j := 2 to i-1 do begin if i mod j = 0 then begin for k := 2 to j-1 do begin if j mod k = 0 then del2 := del2 + 1; end; if del2 = 0 then del1 := del1 + 1; del2 := 0; end; end; if del1 = 3 then begin count := count + 1; if min > i then min := i; end; del1 := 0; end; writeln(count, min);end.Результат работы программы —
Осталось ещё 1 шаг
Приведем другое решение. Будем раскладывать…
Бесплатно · займёт минуту