Определите количество подходящих чисел, принадлежащих отрезку [10 001
Условие
Назовём натуральное число подходящим, если у него больше 17 различных делителей (включая единицу и само число). Определите количество подходящих чисел, принадлежащих отрезку [10 001; 50 000], а также наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем наименьшее число.
Ответ
Ответ и полный разбор откроются после входа
Посмотреть ответРешение по шагам
Как рассуждать
Решение. Решим задачу перебором. Приведём решение данной задачи на языке Паскаль:var del, count, min, i, j: longint;begin count := 0; del := 0; min := 50001; for i := 10001 to 50000 do begin for j := 1 to i do begin if i mod j = 0 then del := del + 1; end; if del > 17 then begin count := count + 1; if min > i then min := i; end; del := 0; end; writeln(count, min);end.Результат работы программы —
Осталось ещё 1 шаг
Полный разбор с проверкой ответа
Бесплатно · займёт минуту