Определите количество подходящих чисел, принадлежащих отрезку [22 000
Условие
Назовём натуральное число подходящим, если ровно два из его делителей входят в список (11, 13, 17, 19). Определите количество подходящих чисел, принадлежащих отрезку [22 000; 33 000], а также наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем, без разделительных знаков, наименьшее число.
Ответ
Ответ и полный разбор откроются после входа
Посмотреть ответРешение по шагам
Как рассуждать
Решение. Решим задачу перебором. Приведём решение данной задачи на языке Паскаль:var del, count, min, i: longint;begin count := 0; del := 0; min := 33001; for i := 22000 to 33000 do begin if i mod 11 = 0 then del := del + 1; if i mod 13 = 0 then del := del + 1; if i mod 17 = 0 then del := del + 1; if i mod 19 = 0 then del := del + 1; if del = 2 then begin count := count + 1; if min > i then min := i; end; del := 0; end; writeln(count, min);end.Результат работы программы —
Осталось ещё 1 шаг
Полный разбор с проверкой ответа
Бесплатно · займёт минуту