Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех
Условие
Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех из них, которые делятся на 4 и при этом заканчиваются на 6. Программа должна вывести одно число: сумму чисел, введенных с клавиатуры, кратных 4 и оканчивающихся на 6. Пример работы программы: Входные данные | Выходные данные | 12 16 36 26 30 | 52 |
Формат задания
Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.
Решение по шагам
Как рассуждать
Решение. var i, sum, а : integer; begin sum := 0; for i := 1 to 5 do begin readln(a); if (a mod 4=0) and (a mod 10 =
Осталось ещё 2 шага
then sum := sum + a; end; writeln(sum); end…
| and (a % 10 == 6): sumi += aprint(sumi) Для…
Бесплатно · займёт минуту
Другие задачи по теме «Программирование»
Программа получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 класс