Присоединиться

9 класс·средний уровень

Программа получает на вход количество чисел в последовательности, а

Условие

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число — сумму чисел, оканчивающихся на 4. Пример работы программы: Входные данныеВыходные данные
3 14 25 2438

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. var n, s, k, g: integer;begin s:=0; readln(n); for k:=1 to n do begin readln(g); if (g mod 10 =

Осталось ещё 1 шаг

  1. then s:=s+g; end; writeln(s);end. Приведем…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»