Присоединиться

11 класс·высокий уровень

Укажите используемый язык программирования и его версию.

Условие

На вход программы поступает последовательность из N натуральных чисел. Рассматриваются все пары различных элементов последовательности, у которых различные остатки от деления на d = 160 и хотя бы одно из чисел делится на p = 7. Среди таких пар, необходимо найти и вывести пару с максимальной суммой элементов. Описание входных и выходных данных.В первой строке входных данных задаётся количество чисел N (1 ≤ N ≤ 1000). В каждой из последующих N строк записано одно натуральное число, не превышающее 10000. В качестве результата программа должна напечатать элементы искомой пары. Если среди найденных пар максимальную сумму имеют несколько, то можно напечатать любую из них. Если таких пар нет, то вывести два нуля.

Пример входных данных:41687320328Пример выходных данных для приведённого выше примера входных данных:168 320Пояснение: Из 4 чисел можно составить 6 пар. В данном случае условиям удовлетворяют пары: 168 и 320, 168 и 7, 320 и 7, 328 и 7. Максимальную сумму дает пара 168 и 320.Требуется написать эффективную по времени и по памяти программу для решения описанной задачи. Программа считается эффективной по времени, если при увеличении количества исходных чисел N в k раз время работы программы увеличивается не более чем в k раз. Программа считается эффективной по памяти, если память, необходимая для хранения всех переменных программы, не превышает 1 Кбайт и не увеличивается с ростом N.Максимальная оценка за правильную (не содержащую синтаксических ошибок и дающую правильный ответ при любых допустимых входных данных) программу, эффективную по времени и по памяти, — 4 балла. Максимальная оценка за правильную программу, эффективную только по времени — 3 балла. Максимальная оценка за правильную программу, не удовлетворяющую требованиям эффективности, — 2 балла. Вы можете сдать одну программу или две программы решения задачи (например, одна из программ может быть менее эффективна). Если Вы сдадите две программы, то каждая из них будет оцениваться независимо от другой, итоговой станет бо́льшая из двух оценок.

Перед текстом программы обязательно кратко опишите алгоритм решения. Укажите используемый язык программирования и его версию. Пояснения для проверяющих.1. Задание Б является усложнением задания А. Если в качестве решения задания Б представлено решение задания А, то согласно приведённым ниже критериям, его оценка будет такой же, как если бы это решение было представлено в качестве решения задания А.2. Два задания и, соответственно, возможность для экзаменуемого представить две программы дают ученику возможность (при его желании) сначала написать менее сложное и менее эффективное решение (задание А), которое даёт ему право получить два балла, а затем приступить к поиску более эффективного решения. 3. Каждая из программ, представленных экзаменуемым (но не более двух), оценивается по нижеследующим критериям. В качестве итоговой оценки берётся наибольшая из двух оценок.

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. Отметим:m71 самое большое число кратное 7;m72 второе по величине число кратное 7 и остаток от деления на 160 не равен остатку от деления m71 на 160;m1 самое большое число не кратное 7;m2 второе по величине число не кратное 7 и остаток от деления на 160 не равен остатку от деления m71 на

Осталось ещё 24 шагов

  1. Программа на языке Паскаль. Программа…

  2. and (x mod 160 = m71 mod…

  3. and (x > m71) then m71 := x else if (x mod 7 =…

  4. and (x mod 160 <> m71 mod…

  5. and (x > m71) then begin m72 := m71; m71 :=…

  6. and (x mod 160 <> m71 mod…

  7. and (x > m72) then m72 := x else if (x mod…

  8. and (x mod 160 = m1 mod…

  9. and (x > m1) then m1 := x else if (x mod 7 <>…

  10. and (x mod 160 <> m1 mod…

  11. and (x > m1) then begin m2 := m1; m1 := x…

  12. and (x mod 160 <> m1 mod…

  13. and (x > m2) then m2 := x; end;if (m71 =…

  14. then writeln(0, ' ', 0)else if (m72 =…

  15. and (m71 mod 160 = m1 mod…

  16. then writeln(0, ' ', 0)elsebegin if…

  17. then begin max1 := m71; max2 := m1; end; if…

  18. then begin max1 := m71; max2 := m2; end; if…

  19. <> (m1 mod 160))) then begin max1 := m72…

  20. Программа на языке Python…

  21. Программа эффективна по времени и памяти. n =…

  22. and (x % 160 == m71 %…

  23. and (x > m71): m71 = x elif (x % 7 ==…

  24. and (x % 160 != m71 %…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»

Укажите используемый язык программирования и его версию. — решение с объяснением | Lom Ai