Программа получает на вход натуральные числа, количество введенных
Условие
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 8 и оканчивающихся на 6. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех натуральных чисел, кратных 8 и оканчивающихся на 6. Пример работы программы: Входные данные | Выходные данные | 16 24 56 22 12 0 | 72 |
Формат задания
Решение по шагам
Как рассуждать
Решение. var a, s: integer; begin s: = 0; readln(a); while a<>0 do begin if (a mod 8=0) and (a mod 10 =
Осталось ещё 2 шага
then s : = s + a; readln(a); end; writeln(s)…
| and (a % 10 == 6): sumi += a a =…
Бесплатно · займёт минуту