Программа получает на вход натуральные числа, количество введенных
Условие
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 2. Пример работы программы: Входные данные | Выходные данные | 112 24 42 49 22 0 | 154 |
Формат задания
Решение по шагам
Как рассуждать
Решение. var a, s: integer; begin s: = 0; readln(a); while a<>0 do begin if (a mod 7 =
Осталось ещё 2 шага
then s : = s + a; readln(a); end; writeln(s)…
| and (a % 10 == 2): sumi += a a =…
Бесплатно · займёт минуту