Программа получает на вход натуральные числа, количество введенных
Условие
Напишите программу, которая в последовательности натуральных чисел определяет количество однозначных чисел, кратных 3. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число: количество однозначных чисел, кратных 3. Пример работы программы: Входные данные | Выходные данные | 121 9 4 0 | 1 |
Формат задания
Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.
Решение по шагам
Как рассуждать
Решение. var s, g: integer;begin s:=0; readln(g); while g<>0 do begin if (g mod 3 =
Осталось ещё 1 шаг
then s:=s+1; readln(g); end; writeln(s);end…
Бесплатно · займёт минуту
Другие задачи по теме «Программирование»
Программа получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 класс