Программа получает на вход натуральные числа, количество введенных
Условие
| Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введенные числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 3 и оканчивающихся на 8. Пример работы программы: Входные данные | Выходные данные |
|---|---|
| 23 48 12 18 34 0 | 66 |
Формат задания
Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.
Решение по шагам
Как рассуждать
Решение. Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Паскаль: var a, s: integer; begin s:= 0; readln(a); while a <> 0 do begin if (a mod 3 =
Осталось ещё 2 шага
then s := s + a; readln(a); end; writeln(s)…
| and (a % 10 == 8): sumi += a a =…
Бесплатно · займёт минуту
Другие задачи по теме «Программирование»
Программа получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 класс