Программа получает на вход натуральные числа, количество введенных
Условие
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех натуральных чисел, кратных 3 и оканчивающихся на 4. Пример работы программы: Входные данные | Выходные данные | 16 24 56 22 54 0 | 78 |
Формат задания
Решение по шагам
Как рассуждать
Решение. var a, s: integer; begin s : = 0; readln(a); while a<>0 do begin if (a mod 3 =
Осталось ещё 2 шага
then s : = s + a; readln(a); end; writeln(s)…
| and (a % 10 == 4): sumi += a a =…
Бесплатно · займёт минуту