Программа получает на вход натуральные числа, количество введенных
Условие
Напишите программу, которая в последовательности натуральных чисел определяет количество всех четных чисел, кратных 9. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число: количество всех четных чисел, кратных 9. Пример работы программы: Входные данные | Выходные данные | 27 24 18 22 36 0 | 2 |
Формат задания
Решение по шагам
Как рассуждать
Решение. var a, s: integer; begin s:= 0; readln(a); while a<>0 do begin if (a mod 2 =
Осталось ещё 2 шага
then s : = s + 1 ; readln(a); end; writeln(s)…
| and (a % 9 == 0): kol += 1 a =…
Бесплатно · займёт минуту