Присоединиться

9 класс·средний уровень

Программа получает на вход количество чисел в последовательности, а

Условие

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введенные числа не превышают 300. Программа должна вывести одно число — сумму чисел, кратных 3. Пример работы программы: Входные данные | Выходные данные | 3 12 25 9 | 21 |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. var n, k, g, h: integer;begin h:= 0; readln(n); for k:=1 to n do begin readln(g); if (g mod 3 =

Осталось ещё 1 шаг

  1. | then h:=h+g; end; writeln(h);end. Приведем…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»