Присоединиться

9 класс·высокий уровень

Программа получает на вход количество чисел в последовательности, а

Условие

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4, но не кратных 7. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4 и не кратное 7. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 4, но не кратных 7. Пример работы программы:Входные данные | Выходные данные | 4 16 28 26 24 | 2 |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. var n, i, a, k: integer; begin readln(n); k := 0; for i := 1 to n do begin readln(a); if (a mod 4 =

Осталось ещё 1 шаг

  1. | then k:=k+1; end; writeln(k);end. Приведем…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»

Программа получает на вход количество чисел в последовательности, а — решение с объяснением | Lom Ai