Присоединиться

9 класс·средний уровень

Программа получает на вход количество чисел в последовательности, а

Условие

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 2. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 2.Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000.Программа должна вывести одно число: минимальное число, оканчивающееся на 2.Пример работы программы:Входные данные | Выходные данные | 3 22 12 36 | 12 |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. var n, k, g, h: integer;begin h:= 30000; readln(n); for k:=1 to n do begin readln(g); if (g mod 10 =

Осталось ещё 1 шаг

  1. and (g < h) then h:=g; end; writeln(h);end…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»