Присоединиться

9 класс·средний уровень

Программа получает на вход количество чисел в последовательности, а

Условие

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 9.Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000.Программа должна вывести одно число: количество чисел, оканчивающихся на 9.Пример работы программы:Входные данные | Выходные данные | 3 19 29 24 | 2 |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. var n, i, a, k: integer;begin readln(n); k := 0; for i := 1 to n do begin readln(a); if (a mod 10 =

Осталось ещё 1 шаг

  1. | then k := k + 1; end; writeln(k);end…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»