Программа получает на вход количество чисел в последовательности, а
Условие
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число — минимальное число, оканчивающееся на 6. Пример работы программы: Входные данные | Выходные данные | 3 26 16 36 | 16 |
Формат задания
Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.
Решение по шагам
Как рассуждать
Решение. var n, k, g, h: integer;begin h:= 30000; readln(n); for k:=1 to n do begin readln(g); if (g mod 10 =
Осталось ещё 1 шаг
and (g < h) then h:=g; end; writeln(h);end…
Бесплатно · займёт минуту
Другие задачи по теме «Программирование»
Программа получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 класс