Программа получает на вход количество чисел в последовательности, а
Условие
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа.В последовательности всегда имеется число, оканчивающееся на 8.Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести одно число: сумму чисел, оканчивающихся на 8. Пример работы программы:Входные данные | Выходные данные | 3 18 28 24 | 46 |
Формат задания
Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.
Решение по шагам
Как рассуждать
Решение. var n, i, a, s: integer;begin readln(n); s := 0; for i := 1 to n do begin readln(a); if (a mod 10 =
Осталось ещё 1 шаг
| then s := s + a; end; writeln(s);end…
Бесплатно · займёт минуту
Другие задачи по теме «Программирование»
Программа получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 класс