Программа получает на вход целые числа, количество введенных чисел
Условие
Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму четных чисел. Пример работы программы: Входные данные | Выходные данные | 4 60 15
| 0 | 3 |
|---|---|
| 64 |
Формат задания
Решение по шагам
Как рассуждать
Решение. var N, a, sum: integer;begin sum := 0; N := 0; readln(a); while a <> 0 do begin N := N + 1; if (a mod 2=0) then sum := sum + a; readln(a); end; writeln(N); writeln(sum)end.
Осталось ещё 1 шаг
| Приведем решение на языке Python.sum = 0num…
Бесплатно · займёт минуту