Программа получает на вход целые числа, количество введенных чисел
Условие
Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести два числа: сумму последовательности и количество четных чисел, кратных 5. Пример работы программы: Входные данные | Выходные данные | 4 60 15
| 0 | 79 |
|---|---|
| 1 |
Формат задания
Решение по шагам
Как рассуждать
Решение. var sum, a, num: integer;begin sum := 0; num := 0; readln (a); while a<>0 do begin sum := sum + a; if (a mod 2=0) and (a mod 5=0) then num := num + 1; readln(a); end; writeln(sum); writeln(num)end. Приведем решение на языке Python.sum = 0num = 0a = int(input())while a != 0: sum += a if (a % 2 ==
Осталось ещё 1 шаг
| and (a % 5 == 0): num += 1 a =…
Бесплатно · займёт минуту