Присоединиться

11 класс·высокий уровень

Последовательность натуральных чисел характеризуется числом Х

Условие

Последовательность натуральных чисел характеризуется числом Х — наибольшим числом, кратным 14 и являющимся произведением двух элементов последовательности с различными номерами. Гарантируется, что хотя бы одно такое произведение в последовательности есть. Вам предлагаются два задания, связанные с этой задачей: задание А и задание Б. Вы можете решать оба задания А и Б или одно из них по своему выбору.

Итоговая оценка выставляется как максимальная из оценок за задания А и Б. Если решение одного из заданий не представлено, то считается, что оценка за это задание составляет 0 баллов.

Задание Б является усложненным вариантом задания А, оно содержит дополнительные требования к программе. А. Напишите на любом языке программирования программу для решения поставленной задачи, в которой входные данные будут запоминаться в массиве, после чего будут проверены все возможные пары элементов.

Перед программой укажите версию языка программирования. Обязательно укажите, что программа является решением задания А.Максимальная оценка за выполнение задания А - 2 балла. Б. Напишите программу для решения поставленной задачи, которая будет эффективна как по времени, так и по памяти (или хотя бы по одной из этих характеристик).Программа считается эффективной по времени, если время работы программы пропорционально количеству элементов последовательности N, т. е. при увеличении N в k раз время работы программы должно увеличиваться не более чем в k раз.

Обязательно укажите, что программа является решением задания Б. Перед текстом программы кратко опишите используемый Вами алгоритм решения.

На вход программе в первой строке подаётся количество чисел N. В каждой из последующих N строк записано одно натуральное число, не превышающее 1000.Пример входных данных:540100072855Пример выходных данных для приведённого выше примера входных данных:28000 Пояснения для проверяющих.1. Задание Б является усложнением задания А. Если в качестве решения задания Б представлено решение задания А, то согласно приведённым ниже критериям, его оценка будет такой же, как если бы это решение было представлено в качестве решения задания А.2. Два задания и, соответственно, возможность для экзаменуемого представить две программы дают ученику возможность (при его желании) сначала написать менее сложное и менее эффективное решение (задание А), которое даёт ему право получить два балла, а затем приступить к поиску более эффективного решения. 3. Каждая из программ, представленных экзаменуемым (но не более двух), оценивается по нижеследующим критериям. В качестве итоговой оценки берётся наибольшая из двух оценок.

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. Произведение двух чисел делится на 14, если:— один из сомножителей делится на 14 (второй может быть любым) либо— ни один из сомножителей не делится на 14, но один из сомножителей делится на 7, а другой - на 2.Поэтому программа, вычисляющая число X, может работать так.

    Программа читает все входные данные один раз, не запоминая все данные в массиве. Программа для прочитанного фрагмента входной последовательности хранит значения четырёх величин:М7 - самое большое число, кратное 7, но не кратное 2;M2 - самое большое число, кратное 2, но не кратное 7;M14 - самое большое число, кратное 14;МAX - самое большое число среди всех элементов последовательности, отличное от М14 (если число М14 встретилось более одного раза и оно же является максимальным, то MAX = M14).После того как все данные прочитаны, искомое число X вычисляется как максимум из произведений М14MAX и М7М2.Ниже приведён пример программы на языке Паскаль, которая реализует описанный алгоритм.

    Кроме того, приведён пример программы на языке Бейсик, которая правильно решает задачу, но использует алгоритм, немного отличающийся от описанного выше. Возможны и другие правильные алгоритмы.

    Допускаются решения, записанные на других языках программирования. Пример правильной и эффективной программы на языке Паскальvar M7,M2,M14,MAX,dat,res,i,N: longint;begin M7 := 0; M2 := 0; M14 := 0; MAX := 0; readln(N); for i := 1 to N do begin readln(dat); if ((dat mod

Осталось ещё 4 шага

  1. and (dat > M7) then M7 := dat; if ((dat mod…

  2. and (dat > M2) then M2 := dat; if (dat mod…

  3. and (dat > M14) then begin if M14 > MAX then…

  4. then max := a[i] * a[j]; writeln(max);end…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»