Напишите программу, которая по двум данным натуральным числам a и b, не
Условие
Напишите программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество четных натуральных чисел на отрезке [a, b] (включая концы отрезка). Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1 ≤ a ≤ b ≤ 30000. Проверять входные данные на корректность не нужно. Программа должна вывести одно число: количество четных чисел на отрезке [a, b]. Пример работы программы:
| Входные данные | Выходные данные |
|---|---|
| 10 20 | 6 |
Формат задания
Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.
Решение по шагам
Как рассуждать
Вариант решения на языке Паскаль.var a, b, count, i: integer;begin read(a, b); count:=0; for i := a to b do begin if i mod 2 = 0 then count := count + 1; end; writeln(count);end.
Осталось ещё 1 шаг
Приведем другое решение на языке Python. a =…
Бесплатно · займёт минуту
Другие задачи по теме «Программирование»
Программа получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 классПрограмма получает на вход количество чисел в последовательности, а9 класс