Присоединиться

9 класс·высокий уровень

На контрольной работе по алгебре ученикам 9 класса было предложено 10

Условие

Напишите программу для решения следующей задачи. На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решенных примеров. Пример работы программы:

Входные данныеВыходные данные
4 3 9 2 82NO

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Вариант решения на языке Паскаль.var a, success, count, N, i: integer;begin count:= 0; readln(N); for i := 1 to N do begin readln(a); if a < 5 then count := count + 1; if a = 10 then success := 1; end; writeln(count); if success = 1 then writeln('YES') else writeln('NO');end.

Осталось ещё 1 шаг

  1. Приведем другое решение на языке Python…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»

На контрольной работе по алгебре ученикам 9 класса было предложено 10 — решение с объяснением | Lom Ai