Камера наблюдения регистрирует в автоматическом режиме скорость
Условие
Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей, округляя значения скорости до целых чисел. Необходимо определить минимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была больше 80 км/ч, выведите «YES», иначе выведите «NO».Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300.Программа должна сначала вывести минимальную скорость, затем YES или NO. Пример работы программы: Входные данные | Выходные данные | 4 74 69 63
| 96 | 63 |
|---|---|
| YES |
Формат задания
Решение по шагам
Как рассуждать
Решение. var N, a, i, min: integer;b: boolean;begin min := 301; b := false; readln(N); for i := 1 to N do begin readln(a); if a < min then min := a; if a > 80 then b := true; end; writeln(min); if b = true then writeln('YES') else writeln('NO')end.
Осталось ещё 1 шаг
Приведем решение на языке Python.min = 301b =…
Бесплатно · займёт минуту