Присоединиться

9 класс·высокий уровень

Камера наблюдения регистрирует в автоматическом режиме скорость

Условие

Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей, округляя значения скорости до целых чисел. Необходимо определить:

  1. разность максимальной и минимальной скоростей автомобилей;

  2. количество автомобилей, скорость которых не превышала 30 км/ч. Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести разность максимальной и минимальной скоростей автомобилей, затем количество автомобилей, скорость которых не превышала 30 км/ч. Пример работы программы: Входные данные | Выходные данные | 4 74 69 63

9633
0

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. var N, a, i, max, num, min: integer;begin max := 0; min := 301; num := 0; readln(N); for i := 1 to N do begin readln(a); if a > max then max := a; if a < min then min := a; if a <= 30 then num := num + 1; end; writeln(max - min); writeln(num)end.

Осталось ещё 1 шаг

  1. | Приведем решение на языке Python.max = 0min…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»