Камера наблюдения регистрирует в автоматическом режиме скорость
Условие
Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей, округляя значения скорости до целых чисел. Необходимо определить среднюю зарегистрированную скорость всех автомобилей. Если не менее двух автомобилей двигались со скоростью не больше 40 км/ч, выведите «YES», иначе выведите «NO».Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300.Программа должна сначала вывести среднюю скорость, с точностью до одного знака после запятой, затем «YES» или «NO». Пример работы программы: Входные данные | Выходные данные | 4 74 69 63
| 96 | 75.5 |
|---|---|
| NO |
Формат задания
Решение по шагам
Как рассуждать
Решение. var N, a, i, num: integer;s, ave: real;begin s := 0.0; num := 0; readln(N); for i := 1 to N do begin readln(a); s := s+a; if a <= 40 then num := num + 1; end; ave := s/N; writeln(ave:6:1); if num >= 2 then writeln('YES') else writeln('NO')end.
Осталось ещё 1 шаг
| Приведем решение на языке Python.s = 0.0b =…
Бесплатно · займёт минуту