Для заданной последовательности целых неотрицательных чисел необходимо
Условие
Для заданной последовательности целых неотрицательных чисел необходимо найти минимальное произведение двух её элементов, различающихся порядковыми номерами не менее чем на 6. Значение каждого элемента последовательности не превышает 1000. Количество элементов последовательности не превышает 10000 и не менее 7. Вам предлагается два задания, связанных с этой задачей: задание А и задание Б. Вы можете решать оба задания или одно из них по своему выбору. Итоговая оценка выставляется как максимальная из оценок за задания А и Б. Если решение одного из заданий не представлено, то считается, что оценка за это задание — 0 баллов.Задание Б является усложнённым вариантом задания А, оно содержит дополнительные требования к программе. А. Напишите на любом языке программирования программу для решения поставленной задачи, в которой входные данные будут запоминаться в массиве, после чего будут проверены все возможные пары элементов. Перед программой укажите версию языка программирования.Обязательно укажите, что программа является решением задания А. Максимальная оценка за выполнение задания А — 2 балла.Б. Напишите программу для решения поставленной задачи, которая будет эффективна как по времени, так и по памяти (или хотя бы по одной из этих характеристик). Программа считается эффективной по времени, если время работы программы пропорционально количеству полученных показаний прибора N, т. е. при увеличении N в k раз время работы программы должно увеличиваться не более чем в k раз. Программа считается эффективной по памяти, если размер памяти, использованной в программе для хранения данных, не зависит от числа N и не превышает 1 килобайта.Перед программой укажите версию языка программирования и кратко опишите использованный алгоритм.Обязательно укажите, что программа является решением задания Б. Максимальная оценка за правильную программу, эффективную по времени и по памяти, — 4 балла.Максимальная оценка за правильную программу, эффективную по времени, но неэффективную по памяти, — 3 балла.Напоминаем! Не забудьте указать, к какому заданию относится каждая из представленных Вами программ. Первое число подаваемое на вход программы — количество элементов последовательности. Критерии оценивания выполнения задания | Баллы | Критерии оценивания задания А | | Программа решает поставленную задачу для любых соответствующих условию входных данных. Например, допускается переборное решение, аналогичное приведённой выше Программе 1.Допускается до семи синтаксических и приравненных к ним ошибок (см. критерии оценивания задания Б на 4 балла).Допускается до двух содержательных ошибок, описанныхв критериях оценивания задания Б на 3 балла | 2 | Не выполнены условия, позволяющие поставить 2 балла.Из описания алгоритма или общей структуры программы видно, что экзаменуемый в целом правильно представляет путь решения задачи независимо от эффективности. При этом программа может быть представлена отдельными фрагментами, без ограничений на количество синтаксических и содержательных ошибок. 1 балл ставится также за решения, верные лишь в частных случаях | 1 | Не выполнены критерии, позволяющие поставить 1 или 2 балла | 0 | Максимальный балл для задания А | 2 | Критерии оценивания выполнения задания Б | Баллы | Программа правильно работает для любых соответствующих условию входных данных и при этом эффективна как по времени, так и по памяти, т.е. не используются массивы и другие структуры данных, размер которых зависит от количества входных элементов, а время работы пропорционально этому количеству. Возможно использование массивов и динамических структур данных (например, контейнеры STL в программе на языке С++) при условии, что в них в каждый момент времени хранится фиксированное количество элементов, требующих для хранения меньше 1кб (минимально необходимое количество — шесть; допускается решение с запасом).Программа может содержать не более трёх синтаксических ошибок следующих видов:— пропущен или неверно указан знак пунктуации (запятая, точка с запятой, скобки и т.д.);— неверно написано или пропущено служебное слово языка программирования;— не описана или неверно описана переменная;— применяется операция, недопустимая для соответствующего типа данных. К синтаксическим ошибкам приравнивается использование неверного типа данных (например, использование целого типа вместо вещественного для представления данных при вводе и обработке).Если одна и та же ошибка встречается несколько раз, она считается за одну ошибку | 4 | Не выполнены условия, позволяющие поставить 4 балла.Программа правильно работает для любых соответствующих условию входных данных, время работы пропорционально количеству входных элементов. Размер используемой памяти не имеет значения и может зависеть от объёма входных данных. В частности, допускается использование одного или нескольких массивов размера N (как в приведённой выше программе 3).Программа может содержать не более пяти синтаксических и приравненных к ним ошибок, описанных в критериях на 4 балла.Кроме того, допускается наличие не более одной содержательной ошибки из числа следующих:— неверная инициализация при поиске минимального значения;— неверная обработка начальных элементов данных, которая может, например, привести к получению ошибочного ответа при 15 < N < 30;— неточное определение границ массива, выход за границу массива (например, описан массив с границами от 1 до 15, а реально используется от 0 до 14 или наоборот);— вычисленный индекс элемента массива на 1 отличается от верного;— используется операция "<" вместо "<=", "or" вместо "and" и т.п.;— не учитывается, что заданные показания могут начинаться с одного или нескольких чётных чисел;— не учитывается, что для данного набора показаний может не быть ни одного удовлетворяющего условиям произведения | 3 | Не выполнены условия, позволяющие поставить 3 или 4 балла. Программа работает в целом верно, эффективно или нет. Например, допускается переборное решение, аналогичное приведённой выше программе 4. Допускается до семи синтаксических и приравненных к ним ошибок (см. критерии на 4 балла).Допускается до двух содержательных ошибок, описанных в критериях на 3 балла | 2 | Не выполнены условия, позволяющие поставить 2, 3 или 4 балла. Из описания алгоритма или общей структуры программы видно, что экзаменуемый в целом правильно представляет путь решения задачи независимо от эффективности. При этом программа может быть представлена отдельными фрагментами, без ограничений на количество синтаксических и содержательных ошибок. 1 балл ставится также за решения, верные лишь в частных случаях | 1 | Не выполнены критерии, позволяющие поставить 1, 2, 3 или 4 балла | 0 | Максимальный балл для задания Б | 4 | Итоговый максимальный балл | 4 |
Формат задания
Решение по шагам
Как рассуждать
Задание А.Используемый язык: Dev — C++ #include <iostream>using namespace std;int main () { int a[10000]; int minb, i, j, N; cin >> N; for (i = 0; i < N; i++) // ввод значений в массив cin >> a[i]; min = 10001000 + 1; for (i = 0; i < N - 6; i++) { for (j = i + 6; j < N; j++) { //просмотрим каждую возможность if (a[i] * a[j] < minb) minb = a[i] * a[j]; } } cout << minb; return(0);}Задание А.Используемый язык: Паскаль ABC.var a: array[1..10000] of integer; {исходные данные} N: integer; minb: integer; {искомое минимальное произведение пары чисел} i, j: integer;begin readln(N); for i := 1 to N do readln(a[i]); minb := 10001000+1; for i := 1 to N-6 do for j := i+6 to N do if (a[i]*a[j] < minb) then minb := a[i]*a[j]; writeln(minb);end.
Осталось ещё 1 шаг
Шаг 2
Бесплатно · займёт минуту