Присоединиться

11 класс·высокий уровень

Датчик передаёт каждую секунду по каналу связи неотрицательное целое

Условие

Датчик передаёт каждую секунду по каналу связи неотрицательное целое число, не превосходящее 1000 — текущий результат измерений. Временем, в течение которого происходит передача, можно пренебречь.

Необходимо найти в заданной серии показаний датчика минимальное чётное произведение двух показаний, между моментами передачи которых прошло не менее 15 секунд. Если получить такое произведение не удаётся, ответ считается равным -1. Общее количество показаний датчика в серии не превышает 10 000. Вам предлагается два задания, связанных с этой задачей: задание А и задание Б. Вы можете решать оба задания или одно из них по своему выбору. Итоговая оценка выставляется как максимальная из оценок за задания А и Б. Если решение одного из заданий не представлено, то считается, что оценка за это задание — 0 баллов.

Задание Б является усложнённым вариантом задания А, оно содержит дополнительные требования к программе. А. Напишите на любом языке программирования программу для решения поставленной задачи, в которой входные данные будут запоминаться в массиве, после чего будут проверены все возможные пары элементов. Перед программой укажите версию языка программирования.

Обязательно укажите, что программа является решением задания А. Максимальная оценка за выполнение задания А — 2 балла.Б. Напишите программу для решения поставленной задачи, которая будет эффективна как по времени, так и по памяти (или хотя бы по одной из этих характеристик). Программа считается эффективной по времени, если время работы программы пропорционально количеству полученных показаний прибора N, т. е. при увеличении N в k раз время работы программы должно увеличиваться не более чем в k раз. Программа считается эффективной по памяти, если размер памяти, использованной в программе для хранения данных, не зависит от числа N и не превышает 1 килобайта.

Перед программой укажите версию языка программирования и кратко опишите использованный алгоритм.

Обязательно укажите, что программа является решением задания Б. Максимальная оценка за правильную программу, эффективную по времени и по памяти, — 4 балла.

Максимальная оценка за правильную программу, эффективную по времени, но неэффективную по памяти, — 3 балла.

Напоминаем! Не забудьте указать, к какому заданию относится каждая из представленных Вами программ.

Входные данные представлены следующим образом. В первой строке задаётся число N — общее количество показаний датчика. Гарантируется, что N > 15. В каждой из следующих N строк задаётся одно неотрицательное целое число — очередное показание прибора. Пример входных данных:175 4 3 2 16 7 8 9 10 110 120 130 140 150 160 50 Программа должна вывести одно число — описанное в условии произведение, либо −1, если получить такое произведение не удаётся.

Пример выходных данных для приведённого выше примера входных данных:200

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. Задание А. Ниже приводится пример переборного решения на Паскале, не эффективного ни по памяти, ни по времени, но являющимся правильным ответом на задание А.Программа

Осталось ещё 9 шагов

  1. const s = 15; требуемое расстояние между…

  2. and (a[i]*a[j] < mp) then mp := a[i]*a[j]…

  3. Если очередное показание чётное, минимальное…

  4. const s = 15; требуемое расстояние между…

  5. and (a[1] < me) then me := a[1]; if a_ mod…

  6. && (a[k] < nchmin)) // Ищем нечетный миниум…

  7. && ((x * chetmin) < minpr)) // Если показание…

  8. && ((x * absolutmin) < minpr)) minpr = x *…

  9. // Было ли получено произведение cout <<…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Программирование»

Датчик передаёт каждую секунду по каналу связи неотрицательное целое — решение с объяснением | Lom Ai