Присоединиться

Информатика·Задания Д24 C1. Исправление ошибок в программе·11 класс

Укажите, как нужно доработать программу, чтобы не было случаев ее

Условие

Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (x, y - действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы). Программист торопился и написал программу неправильно.

Рисунок к задаче

Паскаль | Бейсик | var x,y: real; beginreadln(x,y); if y<=x+2 then if x<=0 thenif xx+yy<=25 then write('принадлежит') elsewrite('не принадлежит')end. | INPUT x, y IF y<=x+2 THEN IF x<=0 THEN IF xx+yy<=25 THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" ENDIF ENDIF ENDIF END | Си++ | Алгоритмический язык | #include <iostream>using namespace std; int main(){ float x,y;cin >> x >> y; if (y<=x+2) if (x<=0)if (xx+yy<=25)cout << "принадлежит";elsecout << "не принадлежит";} | алгначвещ x,y ввод x,y если y<=x+2 то если x<=0 то если xx+yy<=25 то вывод 'принадлежит' иначевывод 'не принадлежит'всевсевсекон | Python | x = float(input())y = float(input())if y<=x+2: if x<=0: if xx+yy<=25: print("принадлежит") else: print("не принадлежит") | Последовательно выполните следующее.1. Перерисуйте и заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (A, B, C, D, E, F, G и H).Точки, лежащие на границах областей, отдельно не рассматривать. В столбцах условий укажите "да", если условие выполнится, "нет", если условие не выполнится, "—" (прочерк), если условие не будет проверяться, "не изв.", если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце "Программа выведет" укажите, что программа выведет на экран. Если программа ничего не выводит, напишите "—" (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите "не изв". В последнем столбце укажите "да" или "нет". 2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.)

Рисунок к задаче

Область | Условие 1 (y<=2+x) | Условие 2 (x<=0) | Условие 3 (xx+yy<=25) | Программа выведет | Область обрабатывается верно | A | | | | | | В | | | | | | С | | | | | | D | | | | | | Е | | | | | | F | | | | | | G | | | | | | Н | | | | | | K | | | | | | Критерии оценивания выполнения задания | Баллы | Обратите внимание! В задаче требуется выполнить три следующих действия.1. Указать для каждой области, как будет работать программа - заполнить таблицу.2. Исправить ошибку, связанную с неверной расстановкой операторных скобок (отсутствуют случаи ELSE). Исправлением этой ошибки может быть либо добавление случая ELSE к каждомуусловию IF, либо объединение всех условий IF в одно при помощи конъюнкции.В сложных случаях это действие считается выполненным, если программа выдает одно из двух сообщений «принадлежит» или «не принадлежит» для любых чисел x и y, при этом программа не стала работать хуже, чем раньше, то есть для всех точек, для которых программа ранее выдавала верный ответ, доработанная программа также должна выдавать верный ответ.3. Исправить ошибку в проверяемых условиях.В сложных случаях это действие считается выполненным, если верно определена закрашенная область, то есть программа выводит сообщение «принадлежит» для всех точек закрашенной области и только для них, для точек вне закрашенной области программа выводит «не принадлежит» или не выводит ничего.В целом, критерий оценки работ такой: количество баллов равно количеству выполненных действий. Детально критерии для каждого случая рассмотрены ниже. Задание выполнено полностью:1) Правильно заполнена вся таблица.2) Написана правильно работающая программа(исправлены обе ошибки), т.е. программа для всех пар чисел x, y верно определяет принадлежность точки закрашенной области.В работе (во фрагментах программ) допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения. | 3 | Правильно выполнены два действия из трех.При этом:а) Действие по заполнению таблицы засчитывается, даже если ошибки есть, но не более, чем в одной строке.б) При написании операций сравнения допускается одно неправильное использование строгих/нестрогих неравенств (считается несущественной ошибкой, погрешностью записи).Например, вместо «y>=-x» один раз используется «y>-x».в) Если ученик написал программу, которая отличается от правильной программы (с учетом п.б) только расстановкой скобок в логических выражениях (например, неправильно учтеныприоритеты операций), то считается, что выполнено одно действие по исправлению ошибок из двух.В работе (во фрагментах программ) допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения. | 2 | Правильно выполнено только одно действие из трех.При этом:а) Действие по заполнению таблицы засчитывается, если ошибки есть не более, чем в двух строках (в отличие от предыдущего пункта).б) При написании операций сравнения допускается любое количество неправильных использований строгих/нестрогих неравенств (т.е. не учитывается корректность работы программы на границах областей)в) Если ученик написал программу, которая отличается от правильной программы только расстановкой скобок в логических выражениях (например, неправильно учтены приоритетыопераций), то считается, что выполнено одно действие по исправлению ошибок из двух.В работе (во фрагментах программ) допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения. | 1 | Ни один из пунктов задания не выполнен, т.е. не выполнены критерии, позволяющие поставить ученику 1 балл. | 0 | Максимальный балл | 3 |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Ниже разбор по шагам.

Решение по шагам

  1. Как рассуждать

    Решение. Область | Условие 1 (y<=x+2) | Условие 2 (x< =

Осталось ещё 1 шаг — откроются после входа:

  • Шаг 2
Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Задания Д24 C1. Исправление ошибок в программе»

Укажите, как нужно доработать программу, чтобы не было случаев ее — решение с объяснением | Lom Ai