Присоединиться

Информатика·Задания Д24 C1. Исправление ошибок в программе·11 класс

Укажите, как нужно доработать программу, чтобы не было случаев её

Условие

Рисунок к задаче

Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (x, y — действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы).Ученик написал такую программу:Паскаль | Бейсик | var x, y: real; beginreadln(x,у);if у >= 1-х then beginif у <= 2-2xx then write('принадлежит')end elseif у >= xx-5 thenwrite('принадлежит')elsewrite('не принадлежит')end. | INPUT х, у IF у >= 1-х THEN IF у <= 2-2хх THEN PRINT "принадлежит" ELSE IF у >= хх-5 THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" END IF END IF END | Си++ | Алгоритмический язык | #include <iostream>using namespace std; int main (){float x, у;cin >> x >> y;if (y >= 1-х) {if (y <= 2-2xx) cout << "принадлежит";}elseif (y >= xx-5)cout << "принадлежит";elsecout << "не принадлежит";} | алгначвещ х, уввод х, уесли у >= 1-х тоесли у <= 2-2хх товывод 'принадлежит'все иначеесли у >= хх-5 товывод 'принадлежит' иначевывод 'не принадлежит'всевсекон | Python | x = float(input())y = float(input())if у >= 1-х: if у <= 2-2xx: print("принадлежит")else: if у >= xx-5: print("принадлежит") else: print("не принадлежит") | При проверке работы программа выполнялась по шагам для некоторых контрольных значений х и у, при этом был заполнен протокол тестирования. В результате неаккуратного обращения протокол был испорчен, частично сохранились только четыре строки: Область | Условие 1 (у >= 1-x) | Условие 2 (y <= 2−2xx) | Условие 3 (y >= xx−5) | Вывод | Верно | | | | | — | | | | | | принадлежит | нет | | | | | не принадлежит | да | | | | — | | да | Графы протокола содержат следующую информацию. Область - часть плоскости, которой принадлежит проверяемая точка. (Все возможные области отмечены на рисунке буквами А, В, С, ... S.) Условие 1, Условие2, Условие 3 — результат проверки соответствующего условия (да или нет). Если условие не проверялось, в протокол записывался прочерк. Вывод — сообщение, которое вывела программа. Если программа ничего не вывела, в протокол записывался прочерк. Верно — итоговое заключение (да или нет) о правильности результата работы программы при данных значениях х и у. Последовательно выполните следующее.1. Восстановите уцелевшие строки протокола, заполнив все клетки таблицы. Там, где содержание восстанавливается неоднозначно, запишите любое возможное значение. Например, если для нескольких областей получается одинаковая строка таблицы, укажите в графе «Область» любую из этих областей.2. Укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.) Критерии оценивания выполнения задания | Баллы | Выполнены все три действия: верно заполнена таблица, исправлены две ошибки. Программа для всех пар чисел х, у верно определяет принадлежность или непринадлежность точки закрашенной области. Во фрагментах программ допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения.При написании операций сравнения допускается одно неправильное использование строгих/нестрогих неравенств (считается несущественной ошибкой, погрешностью записи). Например, вместо «>,>=хх-5» используется <<у>хх-5» | 3 | Правильно выполнены два действия из трёх: исправлены обе ошибки, но таблица отсутствует либо содержит ошибки, или же приведена верная таблица, но исправлена только одна ошибка программы. Два балла ставится также в случае, если таблица заполнена верно, а в программе правильно записаны все условия, но логическое выражение получилось неверным из-за ошибки в учёте приоритета операций (не расставлены или неверно расставлены скобки).При оценивании этого задания на 2 балла допускается не учитывать корректность работы программ на точках границ областей (вместо нестрогих в решении были использованы строгие неравенства) | 2 | Правильно выполнено только одно действие из трёх, то есть не выполнены условия, позволяющие поставить 2 или 3 балла, и имеет место одна из следующих ситуаций:1. Таблица заполнена и содержит ошибки в не более чем одной строке; ни одна из ошибок не исправлена.2. Таблица не заполнена (или заполнена и содержит ошибки более чем в одной строке); исправлена ровно одна ошибка программы. При этом допускается не учитывать корректность работы программ на точках границ областей (вместо нестрогих неравенств в решении были использованы строгие) | 1 | Не выполнены условия, позволяющие поставить 1, 2 или 3 балла | 0 | Максимальный балл | 3 |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Ниже разбор по шагам.

Решение по шагам

  1. Как рассуждать

    Область | Условие 1 (у >= 1-x) | Условие 2 (y <= 2-2xx) | Условие 3 (y >= x*x-5) | Вывод | Верно | BCDNP | да | нет | — | — | нет | KL | нет | — | да | принадлежит | нет | AHQR | нет | — | нет | не принадлежит | да | G | да | да | — | принадлежит | да |

Осталось ещё 2 шага — откроются после входа:

  • Шаг 2
  • Шаг 3
Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Задания Д24 C1. Исправление ошибок в программе»