Присоединиться

Информатика·Задания Д24 C1. Исправление ошибок в программе·11 класс

Укажите, как нужно доработать программу, чтобы не было случаев её

Условие

Рисунок к задаче

Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (х, у — действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы).Паскаль | Бейсик | var x, у: real;beginreadln(x,y);if xx + yy <= 25 thenif y <= 4 - xx thenif y <= x+1 thenwrite('принадлежит')elsewrite('не принадлежит')end. | INPUT х, у IF xx + уу <= 25 THEN IF y <= 4 - xx THEN IF y <= x + 1 THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" ENDIF END IF END IF END | Си++ | Алгоритмический язык | #include <iostream>using namespace std; int main (void) {float x,y;cin >> x >> y;if (xx + yy <= 25)if (y <= 4 - x * x)if (y <= x + 1)cout << "принадлежит";elsecout << "не принадлежит";} | алгначвещ х,уввод х,уесли х * х + у * у <= 25 тоесли y <= 4 - x * x тоесли y <= x + 1 товывод 'принадлежит'иначевывод 'не принадлежит'всевсевсекон | Python | x = float(input())y = float(input())if xx + yy <= 25: if y <= 4 - x * x: if y <= x + 1: print("принадлежит") else: print("не принадлежит") | При проверке работы программа выполнялась по шагам для некоторых контрольных значений x и y. при этом был заполнен протокол тестирования, содержащий следующую информацию. Область — часть плоскости, которой принадлежит проверяемая точка (все возможные области отмечены на рисунке буквами A, B, C, ... W). Условие 1, Условие 2, Условие 3 — результат проверки соответствующего условия (да или нет). Если условие не проверялось, в протокол записывался прочерк. Вывод — сообщение, которое вывела программа. Если программа ничего не вывела, в протокол записывался прочерк. Верно — итоговое заключение (да или нет) о правильности результата работы программы при данных значениях x и y.В результате неаккуратного обращения протокол был испорчен, частично сохранилось только три строки: Область | Условие 1 (хх+уу <= 25) | Условие 2 (y <= 4 - x * x) | Условие 3 (y <= x + 1) | Вывод | Верно | | да | | | — | | | | | | принадлежит | нет | | | | нет | | нет | Последовательно выполните следующее.1. Восстановите уцелевшие строки протокола, заполнив все клетки таблицы. Там, где содержание восстанавливается неоднозначно, запишите любое возможное значение. Например, если для нескольких областей получается одинаковая строка таблицы, укажите в графе «Область» любую из этих областей.2. Укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы (это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы). Критерии оценивания выполнения задания | Баллы | Выполнены все три действия | 3 | Правильно выполнены два действия из трёх (исправлены обе ошибки, но в пункте 1 задания не приведена таблица (либо таблица содержит ошибки в двух и более строках), либо приведена таблица (которая содержит ошибки не более чем в одной строке), но исправлена только одна ошибка программы). При написании операций сравнения допускается одно неправильное использование строгих/нестрогих неравенств (считается несущественной ошибкой, погрешностью записи). Например, вместо «x>=5» используется «x>5» | 2 | Правильно выполнено только одно действие из трёх, т.е. либо только приведена таблица, которая содержит ошибки в не более чем одной строке, либо таблица не приведена (или приведена и содержит ошибки более чем в одной строке), но исправлена одна ошибка программы. При оценивании этого задания на 1 балл допускается не учитывать корректность работы программ на точках границ областей (вместо нестрогих неравенств в решении были использованы строгие неравенства или наоборот) | 1 | Все пункты задания выполнены неверно (таблица анализа правильности алгоритма не приведена либо содержит ошибки в двух и более строках, программа не приведена либо ни одна из двух ошибок не исправлена) | 0 | Максимальный балл | 3 |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Ниже разбор по шагам.

Решение по шагам

  1. Как рассуждать

    Решение. [рисунок] Для удобства вывода ответа заведём переменную типа boolean, которая будет истиной, если точка принадлежит закрашенной области, и ложью в противном случае. Код на языке Паскаль: ans:=false;if x * x + y * y <= 25 then begin if (y <= x +

Осталось ещё 4 шага — откроются после входа:

  • Шаг 2
  • Шаг 3
  • Шаг 4
  • Шаг 5
Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Задания Д24 C1. Исправление ошибок в программе»

Укажите, как нужно доработать программу, чтобы не было случаев её — решение с объяснением | Lom Ai