Текстовый файл состоит не более, чем из 10⁷ строчных букв английского
Условие
Текстовый файл состоит не более, чем из 10⁷ строчных букв английского алфавита. Найдите максимальную длину подстроки, в которой символы a и d не стоят рядом.
Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с помощью данного алгоритма.
Задание 24
Ответ
Ответ и полный разбор откроются после входа
Посмотреть ответРешение по шагам
Как рассуждать
Решение. Заменяем все вхождения «da» и «ad» на строки «d a» и «a d». Таким образом, между любыми рядом стоящими a и d будет пробел. После этого разделяем строку по пробелам и находим максимальную длину получившихся подстрок. Паскаль | var f: text; s: string; ar_s: array of string; m, i: integer;begin assign(f, '24.txt'); f.reset(); readln(f, s); s := s.replace('da', 'd a').replace('ad', 'a d'); m := 0; ar_s := s.split(); for i := 0 to ar_s.Length - 1 do if ar_s[i].Length > m then m := ar_s[i].Length; writeln(m);end. | Python | f = open('24.txt')s = f.readline()\ .replace('ad', 'a d')\ .replace('da', 'd a')w = list(map(len, s.split()))print(max(w)) | В результате работы данного алгоритма при вводе данных из файла в условии получаем ответ —
Осталось ещё 2 шага
Приведём другое решение. | Минимальная длина…
Примечание. Путь к файлу необходимо указать…
Бесплатно · займёт минуту