Текстовый файл состоит из символов A, B и C.Определите максимальное
Условие
Текстовый файл состоит из символов A, B и C.Определите максимальное количество идущих подряд пар символов AB или CB в прилагаемом файле.
Искомая подпоследовательность должна состоять только из пар AB, или только из пар CB, или только из пар AB и CB в произвольном порядке следования этих пар.
Для выполнения этого задания следует написать программу.24.txt
Ответ
Ответ и полный разбор откроются после входа
Посмотреть ответРешение по шагам
Как рассуждать
Решение. Для решения данной задачи считаем всю строку в переменную s. Заметим, что, исходя из условия, все пары CB можно заменить на AB, либо, наоборот, все пары AB заменить на CB. Далее перебором найдём наибольшую длину последовательности пар AB, встречающуюся в строке s. Приведём решение данной задачи на языке Pascal.var s: string; i, count, maxCount: integer;begin assign(input, 'C:\24.txt'); readln(s); count:=0; maxCount:=0; s := s.Replace('CB', 'AB'); for i:=1 to 100 do if s.Contains('AB' * i) then begin maxCount := i; end; writeln(maxCount);end. В результате работы данного алгоритма при вводе данных из файла в условии получаем ответ —
Осталось ещё 1 шаг
Приведём решение данной задачи на языке…
Бесплатно · займёт минуту