Определите максимальное количество идущих подряд символов, среди
Условие
Текстовый файл содержит только заглавные буквы латинского алфавита (ABC…Z). Определите максимальное количество идущих подряд символов, среди которых не более одной буквы A.Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с помощью данного алгоритма.
Задание 24
Ответ
Ответ и полный разбор откроются после входа
Посмотреть ответРешение по шагам
Как рассуждать
Решение. Будем посимвольно считывать файл. Каждую итерацию цикла while будем увеличивать счётчик k на единицу и использовать её как индекс. Если очередной считанный символ не является буквой A — будем увеличивать счётчик count на единицу. Также будем проверять, больше ли текущее значение счётчика count значения переменной maxlen. Если условие выполняется, будем обновлять значение переменной maxlen — это искомое значение. Если будет встречена буква A, будем проверять, встречена ли она в первый раз. Если до этого букв A в текущей последовательности не встречалось, будем запоминать текущую позицию буквы A и продолжать увеличивать значение счётчика count. Если буква A в текущей последовательности встречается во второй раз, будем присваивать значению счётчика count разность текущей итерации цикла while и индекса первой встреченной буквы A — таким образом будем учитывать и последовательность, начавшуюся от предыдущей встреченной буквы A. Также в этом случае обновим значение переменной i, отвечающей за хранение индекса последней встреченной буквы A. Приведём решение данной задачи на языке PascalABC.var i, count, maxlen, countA, k: integer;c: char;f: text;begin assign(f,'C:\24.txt'); reset(f); maxlen := 0; count := 0; countA := 0; k := 0; while not eof(f) do begin read(f, c); k := k + 1; if c <> 'A' then begin count := count + 1; if count > maxlen then maxlen := count; end else if countA = 0 then begin countA := 1; i := k; count := count + 1; if count > maxlen then maxlen := count; end else if countA = 1 then begin count := k - i; i := k; if count > maxlen then maxlen := count; end; end; writeln(maxlen);end. В результате работы данного алгоритма при вводе данных из файла в условии получаем ответ —
Осталось ещё 2 шага
Приведём решение Виктора Кима на языке…
count_old = count count = 0 else: count += 1m…
Бесплатно · займёт минуту