Присоединиться

11 класс·средний уровень

Необходимо вывести первые 5 таких чисел, и наименьший делитель

Условие

Напишите программу, которая перебирает целые числа, большие 600 000, в порядке возрастания и ищет среди них такие, среди делителей которых есть хотя бы одно число, оканчивающееся на 7, но не равное 7 и самому числу. Необходимо вывести первые 5 таких чисел, и наименьший делитель, оканчивающийся на 7, не равный 7 и самому числу.

Формат вывода: для каждого из 5 таких найденных чисел в отдельной строке сначала выводится само число, затем — наименьший делитель, оканчивающийся на 7, не равный 7 и самому числу. Строки выводятся в порядке возрастания найденных чисел.

Количество строк в таблице для ответа избыточно. Ответ:

Ответ

Ответ и полный разбор откроются после входа

Посмотреть ответ

Решение по шагам

  1. Как рассуждать

    Решение. Будем последовательно рассматривать каждое целое число, большее 600

Осталось ещё 5 шагов

  1. В каждом таком числе будем перебирать…

  2. Встречая первый делитель числа…

  3. do begin halfI := i div 2; for j := 2 to…

  4. then begin writeln(i, ' ', j); count := count…

  5. if n % i == 0), 0)) and (print(n, d) or (c :=…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Обработка целочисленной информации»

Необходимо вывести первые 5 таких чисел, и наименьший делитель — решение с объяснением | Lom Ai