Присоединиться

11 класс·базовый уровень

Найдите все натуральные числа N, принадлежащие отрезку [400 000 000

Условие

Найдите все натуральные числа N, принадлежащие отрезку [400 000 000; 600 000 000], которые можно представить в виде N = 2^m · 3ⁿ, где m — чётное число, n — нечётное число. В ответе запишите все найденные числа в порядке возрастания.

Ответ:

Ответ

Ответ и полный разбор откроются после входа

Посмотреть ответ

Решение по шагам

  1. Как рассуждать

    Решение. Решим задачу перебором. Сгенерируем числа, подходящие под условия задачи. Массив arr2 заполним числами, которые являются чётными степенями двойки, то есть 2⁰, 2², 2⁴ и так далее. А массив arr3 заполним числами, которые являются нечётными степенями тройки, то есть 3¹, 3³, 3⁵ и так далее. Теперь будем последовательно перемножать элементы массивов arr2 и arr3 и искать такие результаты произведения, которые будут лежать в отрезке [400 000 000; 600 000 000], эти числа будем записывать в массив answer. После нахождения всех возможных чисел, удовлетворяющих условию задачи, отсортируем массив answer по возрастанию и выведем на экран все элементы этого массива, отличные от нуля. Приведём решение на языке Pascal.var arr2: array[1..30] of int64; arr3: array[1..20] of int64; answer: array[1..100] of int64; t: int64; i, j, k: integer;begin arr2[1] := 1; arr3[1] := 3; for i := 1 to 100 do answer[i] := 0; for i := 1 to 29 do arr2[i+1] := arr2[i] * 2 * 2; for i := 1 to 19 do arr3[i+1] := arr3[i] * 3 * 3; for i := 1 to 30 do for j := 1 to 20 do begin if ((arr2[i] * arr3[j]) >=

Осталось ещё 8 шагов

  1. and ((arr2[i] * arr3[j]) <=…

  2. then for k := 1 to 100 do if answer[k]…

  3. Таким образом, мы определим значения…

  4. then begin while i mod 3 = 0 do begin i:=i…

  5. and (i=1) then writeln(j); end;end;end…

  6. Если число делится на 4 и 3, то оно делится…

  7. Получим следующую программу: var…

  8. and (i=1) then writeln(j); end; j:=j+12…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Обработка целочисленной информации»