Присоединиться

11 класс·средний уровень

Для каждого найденного числа запишите эти шесть делителей в шесть

Условие

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [95632; 95650], числа, имеющие ровно шесть различных нечётных натуральных делителей (при этом количество четных делителей может быть любым). Для каждого найденного числа запишите эти шесть делителей в шесть соседних столбцов на экране с новой строки. Делители в строке должны следовать в порядке возрастания.

Например, в диапазоне [2; 48] ровно шесть нечётных различных натуральных делителей имеет число 45, поэтому для этого диапазона вывод на экране должна содержать следующие значения: 1 3 5 9 15 45; в диапазоне [480; 489] ровно шесть нечётных различных натуральных делителей имеет число 486, поэтому для этого диапазона вывод на экране должна содержать следующие значения: 1 3 9 27 81 243. Ответ:

Ответ

Ответ и полный разбор откроются после входа

Посмотреть ответ

Решение по шагам

  1. Как рассуждать

    Решение. Решим задачу перебором. Будем проверять количество делителей каждого числа из диапазона, если их количество равно шесть — записываем их в двумерный массив d. После этого выводим эти делители на экран в новой строке. Приведём решение на языке Pascal.var numDel, i, j: longint; d2: array[1..6] of longint;begin for i := 95632 to 95650 do begin numDel := 0; for j := 1 to i do begin if (i mod j =

Осталось ещё 2 шага

  1. then begin numDel := numDel + 1; if numDel >…

  2. then writeln(d2[1], ' ', d2[2], ' ', d2[3], '…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Обработка целочисленной информации»

Для каждого найденного числа запишите эти шесть делителей в шесть — решение с объяснением | Lom Ai