Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.
Условие
Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2. 15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот не пройдет. У Робота есть девять команд. Четыре команды — это команды-приказы:вверх вниз влево вправоПри выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑ вниз ↓, влево ← , вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится. Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент. Еще четыре команды — это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырех возможных направлений:сверху свободно снизу свободно слева свободно справа свободноЭти команды можно использовать вместе с условием «если», имеющим следующий вид:если условие топоследовательность командвсе Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм: если справа свободно товправозакраситьвсе В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:если (справа свободно) и (не снизу свободно) товправовсе Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:нц пока условиепоследовательность командкц Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм: нц пока справа свободно вправокц Выполните задание. На бесконечном поле имеется стена, состоящая из трех последовательных отрезков: вправо, вниз, влево. Все отрезки неизвестной длины. Робот находится в клетке, расположенной в нижнем углу, который образуется вторым и третьим отрезками. На рисунке указан один из возможных способов расположения стены и Робота (Робот обозначен буквой «Р»).

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные под третьим отрезком. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведенного выше рисунка Робот должен закрасить следующие клетки (см. рис.).

При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для любого допустимого расположения стен. Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе. 15.2 Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа.В последовательности всегда имеется число, оканчивающееся на 8.Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести одно число: сумму чисел, оканчивающихся на 8. Пример работы программы:Входные данные | Выходные данные | 3 18 28 24 | 46 |
Формат задания
Решение по шагам
Как рассуждать
Решение. 15.1 Следующий алгоритм выполнит требуемую задачу.нц пока не снизу свободновлевокцвнизвправонц пока не сверху свободнозакраситьвправокц 15.2 Решениеvar n, i, a, s: integer;begin readln(n); s := 0; for i := 1 to n do begin readln(a); if (a mod 10 =
Осталось ещё 1 шаг
| then s := s + a; end; writeln(s);end…
Бесплатно · займёт минуту