Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.
Условие
Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2. 15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды — это команды-приказы:вверх вниз влево вправоПри выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑ вниз ↓, влево ← , вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится. Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.
Еще четыре команды — это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырех возможных направлений:сверху свободно снизу свободно слева свободно справа свободноЭти команды можно использовать вместе с условием «если», имеющим следующий вид:если условие топоследовательность командвсе Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:если справа свободно товправозакраситьвсе В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:если (справа свободно) и (не снизу свободно) товправовсе Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:нц пока условиепоследовательность командкц Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм: нц пока справа свободно вправокц

Выполните задание.
| Робот находится в левой клетке узкого горизонтального коридора. Ширина коридора — одна клетка, длина коридора может быть произвольной. Возможный вариант начального расположения Робота приведен на рисунке (Робот обозначен буквой «Р»):

| Напишите для Робота алгоритм, закрашивающий все клетки внутри коридора и возвращающий Робота в исходную позицию. Например, для приведенного выше рисунка Робот должен закрасить следующие клетки (см. рис.). Алгоритм должен решать задачу для произвольного конечного размера коридора. При исполнении алгоритма Робот не должен разрушиться. Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе. 15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 6 и оканчивающихся на 4. Пример работы программы: Входные данные | Выходные данные |
|---|---|
| 3242554 | 2 |
Формат задания
Решение по шагам
Как рассуждать
Решение. 15.1 Команды исполнителя будем записывать жирным шрифтом, а комментарии, поясняющие алгоритм и не являющиеся его частью, — курсивом. Начало комментария будем обозначать символом «|».| Сначала будем двигаться направо и закрашивать клетки, пока не дойдем до конца коридора.нц пока справа свободнозакрасить вправокц| Закрасим последнюю клетку.закрасить| Теперь вернемся в исходную клетку.нц пока слева свободновлевокц Возможны и другие варианты решения. Допускается использование иного синтаксиса инструкций исполнителя, более привычного для учащихся. Допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения 15.2 Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Паскаль:var i, n, a, s: integer; begin s := 0; readln(n); for i:=1 to n do begin readln(a); if (a mod 6 =
Осталось ещё 1 шаг
then s := s + 1; end; writeln(s); end…
Бесплатно · займёт минуту