Присоединиться

11 класс·высокий уровень

Укажите, как нужно доработать программу, чтобы не было случаев ее

Условие

| Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (х, у — действительные числа) и определяет принадлежность точки заштрихованной области. Программист торопился и написал программу неправильно.

Рисунок к задаче

ПаскальБейсик
var х, у: real;beginreadln(х, у) ;if у <= 2 * х * х thenif х >= −1 thenif у >= 1 thenwrite('принадлежит ')elsewrite('не принадлежит')end.INPUT x, y IF у <= 2 * x * x THEN IF x >= -1 THEN IF у >= 1 THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" ENDIF ENDIF ENDIF END
Си++Алгоритмический язык
int main (void){ float x, y;cin >> x >> y;if (y <= 2 * x * x)if (x >= -1)if (У >= 1)cout << "принадлежит";elsecout << "не принадлежит";}алгначвещ х, уввод х, уесли у <= 2 * х * х тоесли х >= -1 тоесли у >= 1 товывод 'принадлежит'иначевывод 'не принадлежит'всевсевсекон
Python
x = float(input())y = float(input())if у <= 2 * x * x: if x >= -1: if у >= 1: print("принадлежит") else: print("не принадлежит")
Последовательно выполните следующее:

Рисунок к задаче

  1. Перерисуйте и заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (A, B, C, D, E, F, G и H).Точки, лежащие на границах областей, отдельно не рассматривать. В столбцах условий укажите "да", если условие выполнится, "нет", если условие не выполнится, "—" (прочерк), если условие не будет проверяться, "не изв.", если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце "Программа выведет" укажите, что программа выведет на экран. Если программа ничего не выводит, напишите "—" (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите "не изв". В последнем столбце укажите "да" или "нет". 2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.) Область | Условие 1 (у <= 2 * х * х) | Условие 2 (x >= −1) | Условие 3 (у >=
  1. | Программа выведет | Область обрабатывается верно | | A | | | | | | | В | | | | | | | С | | | | | | | D | | | | | | | Е | | | | | | | F | | | | | | | G | | | | | | | Н | | | | | |

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    Решение. Элементы ответа:1. Область | Условие 1 (у <= 2 * х * х) | Условие 2 (x >= −1) | Условие 3 (у >=

Осталось ещё 3 шага

  1. | Программа выведет | Область обрабатывается…

  2. Возможная доработка (Паскаль):if (у <= 2 * х…

  3. then write('принадлежит') elsewrite('не…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Исправление ошибок в программе»

Укажите, как нужно доработать программу, чтобы не было случаев ее — решение с объяснением | Lom Ai