Укажите, как нужно доработать программу, чтобы не было случаев ее
Условие
Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (х, у — действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно.
| Паскаль | Бейсик | ||||
|---|---|---|---|---|---|
| var х,у: real;beginreadln(х,у);if у>=0 then if х<=1.57 thenif y<=sin(x) thenwrite('принадлежит')elsewrite('не принадлежит')end. | INPUT x, у IF y>=0 THEN IF x<=l,57 THEN IF y<=SIN(x) THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" ENDIF ENDIF ENDIF END | ||||
| Си++ | Алгоритмический | ||||
| int main(void){float x,y;cin >> x >> y;if (y>=0)if (x<=l,57)if (y<=sin(x))cout << "принадлежит";elsecout << "не принадлежит"; } | алг нач вещ x,y ввод x,y если y>=0 то если x<=1,57 то если y<=sin(x) то вывод 'принадлежит' иначе вывод 'не принадлежит' все все все кон | ||||
| Python | |||||
| x = float(input())y = float(input())if y>=0: if x<=1,57: if y<=sin(x): print("принадлежит") else: print("не принадлежит") | |||||

Последовательно выполните следующее.1. Перерисуйте и заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (A, B, C, D, E и F).Точки, лежащие на границах областей, отдельно не рассматривать. В столбцах условий укажите "да", если условие выполнится, "нет", если условие не выполнится, "—" (прочерк), если условие не будет проверяться, "не изв.", если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце "Программа выведет" укажите, что программа выведет на экран. Если программа ничего не выводит, напишите "—" (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите "не изв". В последнем столбце укажите "да" или "нет".2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.) Область | Условие 1 (у>=0) | Условие 2 (х<=1.57) | Условие 3 (y<=sin(x)) | Программа выведет | Область обрабатывается верно | | A | | | | | | | В | | | | | | | С | | | | | | | D | | | | | | | Е | | | | | | | F | | | | | |
Формат задания
Решение по шагам
Как рассуждать
Область Условие 1 (у>=0) Условие 2 (х<=1.57) Условие 3 (y<=sin(x)) Программа выведет Область обрабатывается верно A да да да принадлежит нет В да да нет не принадлежит да С нет — — — нет D нет — — — нет Е да да да принадлежит да F да нет — — нет
Осталось ещё 2 шага
Возможная доработка (Паскаль):if (у >=…
and (х <= 1.57) and (у <= sin (х) ) and (х >=…
Бесплатно · займёт минуту