Укажите, как нужно доработать программу, чтобы не было случаев её
Условие
| Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (x, y — действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы).

| Ученик написал такую программу:Паскаль | Бейсик | ||||
|---|---|---|---|---|---|
| var x, y: real; beginreadln(x,y);if y >= x+1 then beginif y <= 2-2xx then write('принадлежит')end elseif y >= x*x-5 thenwrite('принадлежит')elsewrite('не принадлежит')end. | INPUT x, yIF y >= x+1 THENIF y <= 2-2xx THEN PRINT "принадлежит"ELSEIF y >= x*x-5 THENPRINT "принадлежит"ELSEPRINT "не принадлежит" END IF END IF END | ||||
| Си++ | Алгоритмический язык | ||||
| #include <iostream>using namespace std; int main(){float x, y;cin >> x >> y; if (y >= x+1) {if (y <= 2-2xx) cout << "принадлежит";}elseif (y >= x*x-5)cout << "принадлежит";elsecout << "не принадлежит";} | алг начвещ x, yввод x, yесли y >= x+1 тоесли y <= 2-2xx товывод 'принадлежит'всеиначеесли y >= x*x-5 товывод 'принадлежит' иначевывод 'не принадлежит'всевсекон | ||||
| Python | |||||
| x = float(input())y = float(input())if y >= x+1: if y <= 2-2xx: print("принадлежит")else: if y >= x*x-5: print("принадлежит") else: print("не принадлежит") | |||||
| При проверке работы программа выполнялась по шагам для некоторых контрольных значений х и у, при этом был заполнен протокол тестирования. В результате неаккуратного обращения протокол был испорчен, частично сохранились только четыре строки: Область | Условие 1 (у >= x+1) | Условие 2 (y <= 2−2xx) | Условие 3 (y >= x*x−5) | Вывод | Верно |
| — | |||||
| принадлежит | нет | ||||
| не принадлежит | да | ||||
| — | да |
Графы протокола содержат следующую информацию. Область - часть плоскости, которой принадлежит проверяемая точка. (Все возможные области отмечены на рисунке буквами А, В, С, ... S.) Условие 1, Условие2, Условие 3 — результат проверки соответствующего условия (да или нет). Если условие не проверялось, в протокол записывался прочерк. Вывод — сообщение, которое вывела программа. Если программа ничего не вывела, в протокол записывался прочерк. Верно - итоговое заключение (да или нет) о правильности результата работы программы при данных значениях х и у. Последовательно выполните следующее.1. Восстановите уцелевшие строки протокола, заполнив все клетки таблицы. Там, где содержание восстанавливается неоднозначно, запишите любое возможное значение. Например, если для нескольких областей получается одинаковая строка таблицы, укажите в графе «Область» любую из этих областей.2. Укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.)
Формат задания
Решение по шагам
Как рассуждать
Область Условие 1 (у >= x+1) Условие 2 (y <= 2−2xx) Условие 3 (y >= x*x−5) Вывод Верно АВСНК да нет — — нет MN нет — да принадлежит нет PQRG нет — нет не принадлежит да D да да — принадлежит да
Осталось ещё 1 шаг
Для написания правильной программы необходимо…
Бесплатно · займёт минуту