Присоединиться

11 класс·высокий уровень

Укажите, как нужно доработать программу, чтобы не было случаев её

Условие

|

Рисунок к задаче

Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (x, y — действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы).Ученик написал такую программу:ПаскальБейсик
var x, y: real; beginreadln(x,у);if у >= 1-х then beginif у <= 2-2xx then write('принадлежит')end elseif у >= x*x-5 thenwrite('принадлежит')elsewrite('не принадлежит')end.INPUT х, у IF у >= 1-х THEN IF у <= 2-2хх THEN PRINT "принадлежит" ELSE IF у >= х*х-5 THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" END IF END IF END
Си++Алгоритмический язык
#include <iostream>using namespace std; int main (){float x, у;cin >> x >> y;if (y >= 1-х) {if (y <= 2-2xx) cout << "принадлежит";}elseif (y >= x*x-5)cout << "принадлежит";elsecout << "не принадлежит";}алгначвещ х, уввод х, уесли у >= 1-х тоесли у <= 2-2хх товывод 'принадлежит'все иначеесли у >= х*х-5 товывод 'принадлежит' иначевывод 'не принадлежит'всевсекон
Python
x = float(input())y = float(input())if у >= 1-х: if у <= 2-2xx: print("принадлежит")else: if у >= x*x-5: print("принадлежит") else: print("не принадлежит")
При проверке работы программа выполнялась по шагам для некоторых контрольных значений х и у, при этом был заполнен протокол тестирования. В результате неаккуратного обращения протокол был испорчен, частично сохранились только четыре строки: ОбластьУсловие 1 (у >= 1-x)Условие 2 (y <= 2−2xx)Условие 3 (y >= x*x−5)ВыводВерно
—
принадлежитнет
не принадлежитда
—да

Графы протокола содержат следующую информацию. Область - часть плоскости, которой принадлежит проверяемая точка. (Все возможные области отмечены на рисунке буквами А, В, С, ... S.) Условие 1, Условие2, Условие 3 — результат проверки соответствующего условия (да или нет). Если условие не проверялось, в протокол записывался прочерк. Вывод — сообщение, которое вывела программа. Если программа ничего не вывела, в протокол записывался прочерк. Верно — итоговое заключение (да или нет) о правильности результата работы программы при данных значениях х и у. Последовательно выполните следующее.1. Восстановите уцелевшие строки протокола, заполнив все клетки таблицы. Там, где содержание восстанавливается неоднозначно, запишите любое возможное значение. Например, если для нескольких областей получается одинаковая строка таблицы, укажите в графе «Область» любую из этих областей.2. Укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.)

Формат задания

Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.

Решение по шагам

  1. Как рассуждать

    ОбластьУсловие 1 (у >= 1-x)Условие 2 (y <= 2-2xx)Условие 3 (y >= x*x-5)ВыводВерно
    BCDNPданет——нет
    KLнет—дапринадлежитнет
    AHQRнет—нетне принадлежитда
    Gдада—принадлежитда

Осталось ещё 2 шага

  1. Для написания правильной программы необходимо…

  2. and (y>= 2- 2*x*x) and ( x>=…

Получить полное решение

Бесплатно · займёт минуту

Другие задачи по теме «Исправление ошибок в программе»

Укажите, как нужно доработать программу, чтобы не было случаев её — решение с объяснением | Lom Ai