Укажите, как нужно доработать программу, чтобы не было случаев ее
Условие

Требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (х, у - действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы). Программист торопился и написал программу неправильно.
| Бейсик | Паскаль | ||||
|---|---|---|---|---|---|
| INPUT x, у IF y>=xx-2 THEN IF y<=4-xx THEN IF x>=0 THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" END IF END IF END IF END | var х,у: real; beginreadln(х,у); if у>=хх-2 then if у<=4-хх then if x>=0 thenwrite('принадлежит') elsewrite('не принадлежит'end. | ||||
| Си++ | Алгоритмический язык | ||||
| #include <iostream>using namespace std;int main(){float x,у;cin >> x >> y;if (y>=xx-2)if (y<=4-xx)if (x>=0)cout << "принадлежит";elsecout << "не принадлежит";} | алгначвещ х,уввод х,уесли у>=хх-2 тоесли у<=4-хх тоесли х>=0 товывод 'принадлежит'иначевывод 'не принадлежит'всевсевсекон | ||||
| Python | |||||
| x = float(input())y = float(input())if y>=xx-2: if y<=4-xx: if x>=0: print("принадлежит") else: print("не принадлежит") | |||||
| Последовательно выполните следующее.1. Перерисуйте и заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (А, В, С, D, Е, F, G, Н). Точки, лежащие на границах областей, отдельно не рассматривать. Границами областей А и Н являются параболы и ось Оу.В столбцах условий укажите "да", если условие выполнится, "нет", если условие не выполнится, "—" (прочерк), если условие не будет проверяться, "не изв.", если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце "Программа выведет" укажите, что программа выведет на экран. Если программа ничего не выводит, напишите "—" (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите "не изв". В последнем столбце укажите "да" или "нет".2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.)Область | Условие 1 | ||||
| (y >= x*x-2) | Условие 2 | ||||
| (y <= 4-x*x) | Условие 3 | ||||
| (x >= |
- | Программа выведет | Область обрабатывается верно | | | | | A | | | | | | | B | | | | | | | C | | | | | | | D | | | | | | | E | | | | | | | F | | | | | | | G | | | | | | | H | | | | | |
Формат задания
Развёрнутый ответ: короткого ответа здесь нет — оценивается само рассуждение. Разбор откроется после входа.
Решение по шагам
Как рассуждать
Решение. Содержание верного ответа и указания по оцениванию (допускаются иные формулировки ответа, не искажающие его смысла) Элементы ответа:1) Область Условие 1 (y>=x*x-2) Условие 2 (y<=4-x*x) Условие 3 (x>=0) Программа выведет Область обрабатывается верно A да нет — — нет В нет — — — нет С да да нет не принадлежит нет D да да нет не принадлежит да Е да да да принадлежит да F да да да принадлежит да G нет — — — нет Н нет — — — нет
Осталось ещё 1 шаг
Возможная доработка (Паскаль): if (y<=4-x*x)…
Бесплатно · займёт минуту
Другие задачи по теме «Исправление ошибок в программе»
Найдите все ошибки в этой программе (их может быть одна или несколько).11 классНайдите все ошибки в этой программе (их может быть одна или несколько).11 классПравильно выполнены все действия:- указан верный результат для11 классВыполнены все три необходимых действия, и ни одна верная строка не11 классВыполнены все четыре необходимых действия, и ни одна верная строка не11 класс