Укажите, как нужно доработать программу, чтобы не было случаев ее
Условие
Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (х, у — действительные числа) и определяет принадлежность точки заштрихованной области. Программист торопился и написал программу неправильно.

Паскаль | Бейсик | var х,у: real;beginreadln(x,y);if xx+yy >= 4 thenif у >= −2 thenif у <= x thenwrite('принадлежит')elsewrite('не принадлежит')end. | INPUT x, у IF xx+yy >= 4 THEN IF у >= −2 THEN IF у <= x THEN PRINT "принадлежит" ELSE PRINT "не принадлежит" ENDIF ENDIF ENDIF END | Си++ | Алгоритмический язык | int main(void){ float x, у;cin >> x >> y ;if (xx+yy >= 4)if (у >= −2)if (у <= x)cout << "принадлежит";elsecout << "не принадлежит";} | алгначвещ х, уввод х, уесли xx+yy >= 4 тоесли у >= −2 тоесли у <= x товывод 1 принадлежит'иначевывод 1 не принадлежит'всевсевсекон | Python | x = float(input())y = float(input())if xx+yy >= 4: if у >= −2: if у <= x: print("принадлежит") else: print("не принадлежит") | Последовательно выполните следующее:

- Перерисуйте и заполните таблицу, которая показывает, как работает программа при аргументах, принадлежащих различным областям (A, B, C, D, E, F, G и H).Точки, лежащие на границах областей, отдельно не рассматривать. В столбцах условий укажите "да", если условие выполнится, "нет", если условие не выполнится, "—" (прочерк), если условие не будет проверяться, "не изв.", если программа ведет себя по-разному для разных значений, принадлежащих данной области. В столбце "Программа выведет" укажите, что программа выведет на экран. Если программа ничего не выводит, напишите "—" (прочерк). Если для разных значений, принадлежащих области, будут выведены разные тексты, напишите "не изв". В последнем столбце укажите "да" или "нет". 2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, достаточно указать любой способ доработки исходной программы.) Область | Условие 1 (xx+yy >= 4) | Условие 2 (у >= −2) | Условие 3 (у <= x) | Программа выведет | Область обрабатывается верно | A | | | | | | В | | | | | | С | | | | | | D | | | | | | Е | | | | | | F | | | | | | G | | | | | | Н | | | | | | Критерии оценивания выполнения задания | Баллы | Задание выполнено полностью:1) Правильно заполнена вся таблица.2) Написана правильно работающая программа(исправлены обе ошибки), т.е. программа для всех пар чисел x, y верно определяет принадлежность точки закрашенной области.В работе (во фрагментах программ) допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения. | 3 | Правильно выполнены 2 пункта задания из трёх (исправлены обе ошибки, но не заполнена/неправильно заполнена таблица данных, либо правильно заполнена таблица данных, программа правильно работает при большем числе случаев, чем исходная, но не при всех).Например, выдает «принадлежит» для точек, у которых ( ) и (у <== х), и (у >= -2), и (х > 0).При этом не допускается, чтобы программа неправильно работала при тех входных данных, при которых раньше работала правильно (даже если она при этом правильно стала работать при большем количестве входных данных, чем исходная).ИСКЛЮЧЕНИЕ! При написании операций сравнения допускается одно неправильное использование строгих/нестрогих неравенств (считается несущественной ошибкой, погрешностью записи). Например, вместо «х<=0» используется «х<0» (даже если программа при этом стала неверно работать при тех входных данных, при которых раньше работала правильно). Допускается, например, такое решение: if х * х + у * у >= 4 then if у >= -2 then if у <= х thenwrite('принадлежит') elsewrite(1 не принадлежит 1)elsewrite('не принадлежит')elsewrite('не принадлежит')Действие по заполнению таблицы засчитывается, даже если ошибки есть, но не более, чем в одной строке. | 2 | Правильно выполнено только одно действие из трёх. То есть либо только верно заполнена таблица( действие по заполнению таблицы засчитывается, если ошибки есть не более, чем в двух строках), либо заполнена не верно, но имеется, программа, корректно работающая при большем количестве входных данных, чем исходная, но не при всех (допускается применение исключения, описанного в критериях оценки задачи на 2 балла). | 1 | Все пункты задания выполнены неверно. | 0 | Максимальный балл | 3 |
Формат задания
Решение по шагам
Как рассуждать
Решение. Элементы ответа:1. Область | Условие 1 (xx+yy >=
Осталось ещё 4 шага
Шаг 2
Шаг 3
Шаг 4
Шаг 5
Бесплатно · займёт минуту